#1 27th May 2015 12:26:36

Lord_Chris
Lord Commander
Reputation: 145

From: England, United Kingdom
Registered: 14th Aug 2013
Posts: 2,169
Website

Welcome to the new forum!

Welcome to the new forum everybody! smile

There are a few things you should note though. First of all, while the forum looks exactly the same, you can see a lot of differences. If you look at the URL, I've selected to use Search Engine Friendly URLS on the forum from now on, while performance may be slightly slower in peak times, it will be worth it.

The old forum URLs will still work.

Secondly, private messaging: unfortunately, despite several attempts now, I've have been unable to port PMs over to the system. Therefore, all PMs have been lost. Most of your information (such as reputation and user information) should have been ported across fine, it appears to but I only briefly looked. But if something is not right, let me know so I can change it back while I still have database dumps.

I really do apologise, but the old system was optimised so badly that there was pretty much nothing I could do. I could get them over, but each participant of the old PM system had a copy of the conversation, and it was mucking everything up when I was transferring it across. The time I managed to, it knocked out the private message counter and I had ~2800 PMs.

I do however have a database dump of the old PM system on my PC so if anyone would like some of their old messages, let me know through the new PM system.

We also have a WYSIWYG editor installed, I know that Crusader1307 will probably find this very useful for his articles! smile

If however, you're like me, and prefer no to have one, navigate to your profile -> display and uncheck the selected checkbox next to "WYSIWYG editor".

We also have a new feature in the PM; you can now all create up to 5 folders (I think) each to have your messages in your own custom folders. You can block users easier, and we also have the introduction of a global messages box; "New".

Messages will be viewable in your inbox still, but every message that is new will appear in your new box until it's been read or deleted. The other addition in Private messaging is the ability to archive messages, which is your third global inbox. Archived messages cannot be replied to by you, and you can't touch them. They're used only if you want to preserve messages, and can only be viewed or deleted. They cannot be restored.

If you don't want your messenger enabled, no problem. Head to your profile -> privacy and uncheck the box for private messaging. Using this page, you can also check to receive email updates with a new PM and topic subscriptions.

Many of the features are exactly the same, but have been refined using Panther (my own forum software) so it's more efficient. The software is only in beta at the moment, so if you do happen to encounter any database errors or "the requested URL /x-y-z/ was not found on this server", please do let me know over the PM and I'll get those fixed in the next release of the software.

You can choose your own forum style by going to profile -> display and selecting. The default style for the software is "Oxygen".

Finally, I'd like to announce some promotions with the forum software update!

Charles of Tours has been made an admin now after his great work on the adventure! He's being filling in much more of an admin role than a global moderator role lately, and this has been long overdue. With all the work Nigel has been doing for his Siege-That! contest, I think it's just about time he joined the Contributor group. So he finally has!

Really great work both of you, and congratulations!

Last edited by Lord_Chris (27th May 2015 12:58:12)

Offline
  • 8

#2 27th May 2015 16:48:26

Crusader1307
High Emperor
Reputation: 214

From: Azusa, Ca. USA
Registered: 1st Jan 2015
Posts: 8,481

Re: Welcome to the new forum!

Congrats, Charles and Nigel! "Ride To The Sound of The Guns, Lads!""
Thanks Chris  for all your hard work in updating the forums! I was going thru "article submission withdrawal" for the last day!

Last edited by Crusader1307 (27th May 2015 16:49:22)


Ego Sum Re Historica Meritissimus

https://www.strongholdnation.co.uk/history/quiz

Offline
  • 1

#3 27th May 2015 19:07:01

EaglePrince
Knez
Reputation: 146

From: Novi Sad, Serbia
Registered: 6th May 2014
Posts: 2,082
Website

Re: Welcome to the new forum!

You did a great job here! Well done. smile Only I did notice few things. For example, when I clicked on "new posts" from the main forum page I got some error message, I don't recall which one exactly. I believe it was some server error.

Also, this editor seems to work slower on my PC when I use Internet Explorer. In Mozilla it works great. Still, this thing regarding the speed - I am not sure of it, but only it seems that characters appear short time after I type them. When I do to view the source this issue in Internet Explorer is no longer present.

I don't mean to be the one who complains, I only want to help, and I like what you did, although I haven't see all those new stuff I think.

Offline
  • 0

#4 27th May 2015 19:52:06

Lord_Chris
Lord Commander
Reputation: 145

From: England, United Kingdom
Registered: 14th Aug 2013
Posts: 2,169
Website

Re: Welcome to the new forum!

I was going thru "article submission withdrawal" for the last day!

I was suffering withdrawal reading them! big_smile

It's great to see them getting posted again, even though it was only one day, it was a massive miss!

For example, when I clicked on "new posts" from the main forum page I got some error message, I don't recall which one exactly. I believe it was some server error.

Can you let me know which link it was?

Also, this editor seems to work slower on my PC when I use Internet Explorer. In Mozilla it works great.

WYSIWYG editors by tradition, are slower than a standard editor, because the JavaScript has to parse what you're putting in and then display it to you. Though I'm not quite sure what's caused this speed issue, I actually tested this in Internet Explorer 11, I also tested it on the Panther website a few minutes ago and it was also fine displaying in less than half a second after typing (just about usual as far as I can tell)

What version of IE are you using? Do you have any plugins? And most importantly, is JavaScript enabled? Some people don't even know they have it disabled.

You can check by going to:

Tools -> Internet Options -> Security -> Internet -> Custom Level -> Scripting

You can check addons by going to:

Tools -> Internet Options -> Programs -> Manage addons

Offline
  • 0

#5 27th May 2015 20:11:54

EaglePrince
Knez
Reputation: 146

From: Novi Sad, Serbia
Registered: 6th May 2014
Posts: 2,082
Website

Re: Welcome to the new forum!

This is the exact message I get.
ss2_1.jpg
And here is the "new posts" link I followed.
ss1_1.jpg
Next time someone makes a post I could try to see what happens if I follow the link with Mozilla, or I could try cleaning cookies and stuff like that...
It is Internet Explorer 11. The exact version is 11.0.9600.17801.
I checked the add-on now just in case, but as I expected I have disabled java. Should I enable it?
Other than that I do not have any "unusual" add-on installed.

Offline
  • 0

#6 27th May 2015 20:12:59

Charles of Tours
Knight Banneret
Reputation: 65

From: Lovecraft Country
Registered: 16th Apr 2014
Posts: 249

Re: Welcome to the new forum!

Thank you everyone! I'm glad to be part of the administrative team, and am glad that the site is back on too. smile


Mqb938i.png
Do you crave a life of adventure? Check out our Adventures in the Duchy of Riverborne and apply here to join the action!

Offline
  • 1

#7 27th May 2015 20:22:05

EaglePrince
Knez
Reputation: 146

From: Novi Sad, Serbia
Registered: 6th May 2014
Posts: 2,082
Website

Re: Welcome to the new forum!

I do want to add that this PC is not a high end machine, I've got 2GB of RAM, and 2.7 GHz processor (single core). I am sure it would work differently on my other PC though. Also, I am able not to write in WYSIWYG editor, then it would surely work smoothly.

Offline
  • 0

#8 27th May 2015 20:25:56

Lord_Chris
Lord Commander
Reputation: 145

From: England, United Kingdom
Registered: 14th Aug 2013
Posts: 2,169
Website

Re: Welcome to the new forum!

I wouldn't generally have thought that RAM would have much to do with this, but it may. Java is not JavaScript, so that shouldn't make a difference.

In regards to the database error, do you only get this when viewing new posts, and not for example by clicking on the CivCity Rome forum?

Offline
  • 0

#9 27th May 2015 20:30:45

Charles of Tours
Knight Banneret
Reputation: 65

From: Lovecraft Country
Registered: 16th Apr 2014
Posts: 249

Re: Welcome to the new forum!

Seems I get the same error message that EaglePrince does when I click on the "Active" posts section.


Mqb938i.png
Do you crave a life of adventure? Check out our Adventures in the Duchy of Riverborne and apply here to join the action!

Offline
  • 0

#10 27th May 2015 20:40:33

Lord_Chris
Lord Commander
Reputation: 145

From: England, United Kingdom
Registered: 14th Aug 2013
Posts: 2,169
Website

Re: Welcome to the new forum!

I've fixed this, as Charles of Tours has confirmed.

Offline
  • 0

#11 27th May 2015 20:55:19

EaglePrince
Knez
Reputation: 146

From: Novi Sad, Serbia
Registered: 6th May 2014
Posts: 2,082
Website

Re: Welcome to the new forum!

I still get the error when I click on "new posts" though... I tried cleaning cookies and I also tried visiting the forum from Mozilla. Same happens.

Offline
  • 0

#12 27th May 2015 23:28:27

Isaiah
Spearman
Reputation: 12

Registered: 3rd Feb 2015
Posts: 57

Re: Welcome to the new forum!

Congrats Charles and Nigel ..... Neat, you made your own forum software Chris?

Edit: OOPS, Wrong forum master!

Last edited by Isaiah (28th May 2015 21:51:19)


A stronghold/Crusader fanatic. Could care less about the sequels though...

Stronghold / Crusader Tactics Discussion - Join and share your knowledge with everyone!
Crusader Extreme Invasion/Free Build Tutorial

Offline
  • 0

#13 28th May 2015 08:50:09

Lord_Chris
Lord Commander
Reputation: 145

From: England, United Kingdom
Registered: 14th Aug 2013
Posts: 2,169
Website

Re: Welcome to the new forum!

I still get the error when I click on "new posts" though...

Okay, I'm getting this this morning. Not quite sure what was up there, as it was loading just fine yesterday. Maybe caching, I don't know. I've added a note in the development forum to chase this up in the next release and fixed it on this forum.

Neat, you made your own forum software Ste!iger?

Hi Isaiah! Yes, Panther is my own forum software. smile

It's open source so anyone can download it from the downloads page.

Offline
  • 0

#14 28th May 2015 21:06:03

EaglePrince
Knez
Reputation: 146

From: Novi Sad, Serbia
Registered: 6th May 2014
Posts: 2,082
Website

Re: Welcome to the new forum!

That's nice, you're doing great job. Now if I feel ever need to make a forum I would be able to use yours. By the way, I assume it is easily translated into another language, say Serbian? smile I mean, it would require patience and time, but it could be done if needed I believe (by the one who needs it of course).

Offline
  • 0

#15 29th May 2015 08:10:04

Lord_Chris
Lord Commander
Reputation: 145

From: England, United Kingdom
Registered: 14th Aug 2013
Posts: 2,169
Website

Re: Welcome to the new forum!

Yes. It uses language packs so you can choose which language you want in your profile. Though it only has support for English at the moment, the other Developer is currently doing a French language pack. When they're released, we'll include them in the forum as well which means you can use whatever language you like smile

There are some language packs you can download from FluxBB which are similar, but they need to be tweaked a lot to be used with it.

Offline
  • 0

#16 29th May 2015 08:15:55

EaglePrince
Knez
Reputation: 146

From: Novi Sad, Serbia
Registered: 6th May 2014
Posts: 2,082
Website

Re: Welcome to the new forum!

That's nice to hear. smile

By the way, I should tell that the "new posts" link worked well this morning. smile

Offline
  • 0

#17 30th May 2015 10:35:46

Sir DavidSpy
Yeoman
Reputation: 24

From: WI, USA
Registered: 12th Nov 2013
Posts: 42
Website

Re: Welcome to the new forum!

Just thought I'd let you know that aside from the already noted missing private messages I had no issues using the updated forum. Also my belated congratulations to Charles of Tours and Nigel on their promotions.

Offline
  • 0

#18 30th May 2015 11:08:35

Mathew Steel
Earl Marshal
Reputation: 120

From: Wales, United Kingdom
Registered: 27th Aug 2014
Posts: 930

Re: Welcome to the new forum!

The only problem I've had is the new typing system tends to lag a bit (not exactly lag but it's the best way to explain it) through writing this message, I finished 3 seconds before the characters caught up. My PC isn't being pressured by the website at all and my internet speed is more than quick enough (just in case that would be a reason). I do also use IE which as you said will perform slower using this text. Is there any way to fix it? smile

Other than that I love it! The new title colours really are appealing and easier on the eye! big_smile


"When people unite under one will, they become stronger than the sum of their parts."


Stronghold Next Giveaway - Competition

Offline
  • 0

#19 30th May 2015 13:08:08

Lord_Chris
Lord Commander
Reputation: 145

From: England, United Kingdom
Registered: 14th Aug 2013
Posts: 2,169
Website

Re: Welcome to the new forum!

I do also use IE which as you said will perform slower using this text. Is there any way to fix it?

I'll take a look into this, maybe there is some underlying issue that may be present. I'm aware of the emoticon bug, where you can't post images into the editor because the http:// will think

:/

is part of an emoticon. Maybe there's another reason similar.

Offline
  • 0

#20 30th May 2015 14:49:23

EaglePrince
Knez
Reputation: 146

From: Novi Sad, Serbia
Registered: 6th May 2014
Posts: 2,082
Website

Re: Welcome to the new forum!

I just click at "view source" button at the right, and I type with no lag now - just the way we used to type before. cool But using the editor in Internet Explorer without lad would be great. smile

Offline
  • 1

#21 30th May 2015 15:00:38

Mathew Steel
Earl Marshal
Reputation: 120

From: Wales, United Kingdom
Registered: 27th Aug 2014
Posts: 930

Re: Welcome to the new forum!

I just click at "view source" button at the right, and I type with no lag now - just the way we used to type before

Way better thank you EaglePrince! big_smile


"When people unite under one will, they become stronger than the sum of their parts."


Stronghold Next Giveaway - Competition

Offline
  • 0

#22 30th May 2015 15:02:45

EaglePrince
Knez
Reputation: 146

From: Novi Sad, Serbia
Registered: 6th May 2014
Posts: 2,082
Website

Re: Welcome to the new forum!

At your service. big_smile

Offline
  • 0

#23 31st May 2015 21:55:47

Nigel
Duke
Reputation: 51

Registered: 31st Aug 2014
Posts: 619

Re: Welcome to the new forum!

Nice to come back and find that I have been promoted smile 

Thanks Chris and everyone for the good wishes. I will strive to live up to it.

Offline
  • 0

#24 31st May 2015 22:21:04

Mathew Steel
Earl Marshal
Reputation: 120

From: Wales, United Kingdom
Registered: 27th Aug 2014
Posts: 930

Re: Welcome to the new forum!

Oh how rude of me, I hadn't even noticed. Congratulations Nigel on the promotion. Well earned! smile


"When people unite under one will, they become stronger than the sum of their parts."


Stronghold Next Giveaway - Competition

Offline
  • 0

#25 31st May 2015 22:30:47

EaglePrince
Knez
Reputation: 146

From: Novi Sad, Serbia
Registered: 6th May 2014
Posts: 2,082
Website

Re: Welcome to the new forum!

Me neither. Congratulations, Nigel, you earned it. smile Now both of us bear the royal color. smile

Offline
  • 0
Users in this topic: 0 guests, 0 registered users

Board footer

Powered by Aura